Log in
Elgg Technical Support

Elgg Technical Support

Get support from other Elgg users

Elgg 1.8.1 Installation Issue: Requirements Check Page - Rewrite Test Failed

Hi, I am new to elgg, I am trying to install it on my server which is hosted with 1and1 and have a database already set up , I however have not got to a part in the installation where I have to input my database login information. I get stuck on the very first page on installation after clicking next which brings me to a Requirements Check page. and it gives me this information

 

Your server failed the requirements check. After you have fixed the below issues, refresh this page. Check the troubleshooting links at the bottom of this page if you need further assistance.

PHP

  • Your server's PHP satisfies all of Elgg's requirements.

Web server

  • We think your server is running the Apache web server.

    The rewrite test failed and the most likely cause is that AllowOverride is not set to All for Elgg's directory. This prevents Apache from processing the .htaccess file which contains the rewrite rules.

    A less likely cause is Apache is configured with an alias for your Elgg directory and you need to set the RewriteBase in your .htaccess. There are further instructions in the .htaccess file in your Elgg directory.

Database

  • The database requirements are checked when Elgg loads its database.

 

I have installed it in the root directory http://www.mydomain.com/elgg, and have set permissions on the data file to read,write & execute http://www.mydomain.com/data

Have tried multiple installations  placing directories in different places and using different versions of the elgg software with no joy. Can anyone help me out as I would really like to test this software out.

 

Replies

You must log in to post replies.