Log in
Elgg Technical Support

Elgg Technical Support

Get support from other Elgg users

Elgg 1.8.3 Rewrite Problem

  • Public

Elgg 1.8.3 Rewrite Problem

Started by Kai 763 days ago Replies (13)

Hi

after setting up a Ubuntu system i tried to install elgg but i cannot get behind the requierment check page its always says:

Web server

  • We think your server is running the Apache web server.

    The rewrite test failed and the most likely cause is that AllowOverride is not set to All for Elgg's directory. This prevents Apache from processing the .htaccess file which contains the rewrite rules.

    A less likely cause is Apache is configured with an alias for your Elgg directory and you need to set the RewriteBase in your .htaccess. There are further instructions in the .htaccess file in your Elgg directory.

I followed the tutorials for the installation and everthing works fine apache is working mysql is working mod_rewrite is working but permission is correct but elgg dont accept it

does anyof you have a great idea of the problem?

Replies

  • Brett 763 days ago

    How do you know modrewrite is working? Did you follow the installation troubleshooting directions on the wiki?

  • coolsam001 763 days ago

    Well Brett i am facing this error too. I have posted in groups also. This problem was not with any version of elgg 1.7 or 1.6. I tried to install elgg v1.8.3 on my local wamp server but it failed. It showed the same message as Kai got. I cheked the apache mod rewrite but it was ok.Then installed the old version of wamp having old version of php and it got installed. Even on my shared online server i am getting this same error. I cross cheked by installing elgg 1.7.15 and it installed without problems. So don't know why am i getting this error.

  • iionly 763 days ago

    @Brett: I think there might be an issue in Elgg 1.8 in the mod_rewrite check. There have been several reports about failed installations due to the mod_rewrite test (I remember some mentioning Ubuntu as underlying OS especially). Some people also mentioned that they managed to install Elgg 1.7 on the same machines without any problems, i.e. mod_rewrite should work on their servers but only the test in Elgg 1.8 fails. Some people managed to install Elgg 1.8 by disabling the test during installation, but modifying the code surely is not the best solution especially for inexperienced users.

    I don't know what could be the likely reasons for the mod_rewrite test to fail. I can only imagine that it has to do something with the default Apache config used on these servers (virtual server config, default directory permission set by Apache). I don't know if it would be possible to improve the mod_rewrite test used in Elgg to show the real reason the test fails. Improving the test would surely be easier, if someone would be able to find out more about the real reason as this would allow to reproduce the issue for testing.

  • Stumpy 762 days ago

    @iionly

    I have had the same issue with my home ubuntu/apache server set up.  It seems the problem is because (correct me if i'm wrong) the default config is AllowOveride None in /etc/apache2/sites-available/default which (correct me if i'm wrong)is the cause of the problem.

    https://help.ubuntu.com/community/EnablingUseOfApacheHtaccessFiles

    To get around this I simply set AllowOverride to 'All'.  However, when trying to install on my live host who also )how's your luck eh?) uuses ubuntu/apache this isn't possible so the only way I know of getting around this is by disabling the rewrite test in install/ElggRewriteTester.php

    I have noticed that after this is done a different message is displayed informing you (can't remember the exact wording) that elgg couldn't determine if modrewrite is on but you can check manually by clicking "here", which is a hyperlink whch then, if it is on, displays a new page in a new window with "success" written...

    So, I'd like to make a suggestion if I may: during the modrewite test, if it fails, you get a message that explains that "elgg could not determine automatically if modrewite is enabled on your server, this could be due to a server config issue; if you or your host are sure it is deffinately enabled, then you can click "here" to test it manually". Or simply placing the same link for manual testing with the error message. Then if both tests fail allow them to continue with the install regardless but informing them that Elgg will likely not function correctly and they should check their server config or, ask their host to...

    Just my two penny's worth

    regards

    PS

    I think it's a debian issue.

  • Kai 762 days ago

    Hi thanks for the anwsers

    to Brett: i know modrewrite is working becaus i used every possible test for it an all say the same rewrite is working

     

    disabeling the test make the installation posible but without it the elgg site cannot work its imposible to change a setting or activate a new mod

    so the disabeling of the test is not a good idea

    i ther no one who knows how to handle this problem?

  • Burgs 762 days ago

    @All... I have several 1.8x test installs and knew the rewritetest failure should not have failed, so I replaced ?rewritetest at the end of the URL in my address bar with ?database and it continues with the install. Does that make sense? I'm not experiencing anjy problems yet.

  • Stumpy 762 days ago

    @Burges

    Just out of interest,  is your OS a Debian based OS?

    cheers

  • Burgs 762 days ago

    @Stumpy... It's a UK based inexpensive shared hosting with Redhat Enterprise Linux Platform, does that help?

  • Stumpy 762 days ago

    cheers

     

  • Kai 762 days ago

    interessting burgs but on debian is nothing to replace the url looks like that

    http://Server IP/elgg/install.php?step=requirements

  • Stumpy 762 days ago

     think he mean http://Server IP/elgg/install.php?step=database

  • Burgs 762 days ago

    @Stumpy... correcto mondo

    Doh! Sorry guys, it's been a while since my last install.

  • Kai 762 days ago

    ok i tried burgs way and i must say it works

    i dont now how but now the installation is comlete without errors

    thanks to all of you

    and a big thanks to you burgs

You must log in to post replies.