Log in

Jeroen Dalsem

Owner of ColdTrick IT Solutions, developing social networking sites for the dutch market

Stats

  • Category: Widgets
  • License: GNU General Public License (GPL) version 2
  • Updated: 2012-7-26
  • Downloads: 22388
  • Recommendations: 89

Other Projects

View Jeroen Dalsem's plugins

Widget Manager for Elgg 1.7

Manage widgets on profile, (tabbed) dashboard, groups and index

Last updated 237 days ago

Features:

  • Adding widgets from a lightbox
  • Index widgets (with a few different layouts)
  • Group widgets (instead of group profile modules)
  • Provides a lot of new widgets (see below for the widget list)
  • Forcing of widget (incl positioning) on profile/dashboard (also later!)
  • Option to globally hide a specific widgettype (will even hide widget already placed on profile/dashboard)
  • Multi Dashboard (Tabbed Dashboard)

(C) 2009 -2011 ColdTrick IT Solutions

Release Notes:

3.4 (2011-06-07):

  • added: group tasks widgets (tasks plugin)
  • added: tagcloud widget
  • added: optionally prepends the thewire widget with post form (default on)
  • changed: ordering of widgets in lightbox are now alphabetically
  • fixed: page crashes on default widgets configuration => no longer showing widget body
  • fixed: wrong class handler for object => widget
  • fixed: slider widget fix no text -> no slide over
  • removed: group_river_widget moved to group_tools plugin

3.3 (2011-05-24):

  • added: custom url for widget title added for group and index widgets
  • changed: widget options for content_by_tag and rss widget
  • fixed: free_html admin ignore option not working
  • fixed: coding error in rss widget view
  • fixed: Fancybox CSS errors in IE

3.2 (2011-05-06):

  • added: thewire_post widget to post directly to the wire from a widget
  • fixed: socialink layout in index_login widget
  • fixed: group_forum_topics widget when nog items
  • fixed: z-index to low with new fancybox

 

Comments

  • iionly 1048 days ago

    The neverending story with the Widget Manager plugin lol

    With version 3.1 (on Elgg 1.7.8) I had the problem that the widget content was not shown on Profile pages and Dashboard - but only on one installation while it worked on another with the same plugin configuration. After upgrading to Elgg 1.7.9 the widget content did show up but now the widget title bar was missing: the text was displayed but moving was not possible. I thought it might be a caching problem but I didn't get it working.

    With version 3.4 I had the same problem with the widget titles but this time refreshing the cache helped. I thought that finally everything would be alright. But unfortunately that's not the case as an old problem returned: in one of my two test installations the lightbox dialog on the Profile page is not displayed with any content. Instead I only see a small white box. So it's not possible to add any widgets.

    Maybe it's again some problem with the site cache. I don't know. But it's kind of a show-stopper as it seems unpredictable if the Widget Manager plugin will work on my productive site (more so for all users...). I noticed you opened a ticket at Trac referring to a buggy cache refreshing. Could the problems I have with the Widget Manager plugin be due to this (maybe even due to an incomplete refresh)?

  • martinez 1047 days ago

    i have only 4 wigets on Groups widgets configuration list while on profile list there is much more. How can i add more widgets for groups? I need groupriver, would you add this funcionality to new version?

  • Awilu 1045 days ago

    How can I customize my frontpage with widget ? (I use darkgrey plugin as theme).

    Thanks you.

  • iionly 1045 days ago

    @Jeroen:

    I've played a bit more with the Widget Manager plugin on a test installation to possibly find the reason why the lightbox won't open on some profile pages (so far it always worked on the Dashboard).

    I thought that maybe one or more widgets (most likely from 3rd party plugins) would cause the issue. The profile page already was configured prior installation of Widget Manager with some plugins' widgets.

    With Widget Manager enabled I tried to remove all widgets from the profile page of a user account that had the lightbox issue. First thing I noticed that I wasn't able to remove all widgets. For the widgets of the Tidypics plugin (i.e. Latest pics and albums respectively) and also for the widget of the izap_videos plugin the "delete" icon was not there. Instead a javascript:void(0) was displayed in the link bar of FF when hovering over the location where the delete icon should be. When I tried the same on a different account one of the tidypics icons could be removed, but not the other. This time I was using Chrome if that makes any difference...). I also had updated the timestamp in Widget Manager for the default widget layout in the meantime.

    So, I disabled Widget Manager to be able to remove all widgets on the profile page and then enabled it again (on a sidenote, both at enabling and disabling Widget Manager it's necessary to run upgrade.php). After all widgets were removed, I could open the lightbox to add widgets on the profile page without problem. This time also the "delete" icons showed up.

    So, maybe the problem with the lightbox not opening is either due to a non-standard implementation of the widgets in these other plugins (in case of tidypics I've this problem both in version 1.6.8 and 1.7.0). The other possibility is that Widget Manager has a problem handling some widgets. The problem is that other plugins' widgets could cause the same problem. Also, currently it's kind of difficult to install Widget Manager on an existing site with profile pages already populated for example with Tidypics' widgets.

  • martinez 1044 days ago

    Awilu Turn off riverdashboard, go to your main page once you r logged in and you ll see option add widgets to the doashboard. you have to set the permission for each widget separetly, so they can be visible for both logged in and logged out users.

  • S. R. 1001 days ago

    Hi all,

    This is my first post, just want to say thanks to all the members and developers for helping me get my site up although I'm still testing.

    Thanks to Jeroen Dalsem & iionly.  To Jeroen for this cool plug-in, don't know what I would do without it....  and to iionly for helping me with the white box, missing widgets issue.  I'm using v3.6 but recently had the same problems as iionly after enabling "Disable Lazy Loading" (which worked well).  All widgets disappeared, displaying only a white box.

    I followed your advice (iionly), disabled Widget Manager, and removed all remaining widgets from the profile.  After re-enabling Widget Manager, all was good, widgets re-appeared, haven't had a problem since.  Again, thanks!

  • Enrico Salsi 1000 days ago

    I have installed this plugin (version 3.6) on my site. First of all thanks, it is very usefull. I do not understand how configure the default "custom_index page". I can configure the default "profile widgets" and the default "dashboard widgets" using the administration section. When I login to the site using an administrator user I can add widgets on the "custom_index" page but if I login with a normal user I cannot add widgets and i see a blank "custom_index" page. Where is the problem, or what don't I understand ?

    In the administration section I see these voices to manage defaults :

    Manage widgets
    Dashboard widgets
    Profile widgets

    but there isn't a voice Custom_index widgets.

    I have done my tests on a new clean installation (version 1.7.10) with only the plugin "widget manager" installed.

    Thanx in advance