Log in

izap videos 4.2.0b (Youtube Upload / Onserver upload + Embed urls) (10 Jan, 2013) for Elgg 1.7

Full featured video plugin by iZAP

Last updated 462 days ago

izap_videos is a full featured videos plugin for elgg. It can handle YouTube videos upload, On server upload if you have dedicated resources to process videos and off server videos (YouTube, Vimeo, Veoh, Blip, CollegeHumor, 5min etc.).

  1. It supports YouTube uploads if you do not have dedicated resources to host/process uploaded videos by your users.
  2. It supports Youtube, Vimeo, Veoh, Metacafe, Blip, CollegeHumor, 5min.
  3. It also supports Off server videos. Where you can convert video files to flv at your own server. It needs ffmpeg compiled on your server. Supported formats are subject of what your ffmpeg compilation supports.
  4. More sharing options (Twitter, Facebook, LinkedIn, MySpace).
  5. A new customizable flash player. You can change forground and background colors of the flash player according to your need.
  6. Embeddable video code to post videos on other sites which are uploaded on elgg's platform.
  7. Categories support.
  8. River support.
  9. Groups integration.
  10. Now you can enable on server and off server in parallel mode.
  11. Make your videos favorite.

Recommend izap-videos if you really like what we did.

Release Notes:

Release 3.81b

Some css bug fixes related to image place holder.

  1. Now you can choose layout of your play page from izap_videos plugin's admin settings. Nice 3 options are there. Select according to your need.

Release 3.8b

  1. Nice river update for videos. Click on image holder and play video on place.
  2. Video play page with lot's of cool and well placed elements.
  3. Better control over htmlawed plugin. Manage tags from videos admin panel.
  4. Cool listing pages.
  5. AJAXed play page.
  6. Tags related video holder.
  7. New latest videos widget.
  8. New group widget. Some code fixes at group level.
  9. Cool video thumbs with play button.
  10. Category support ( bug in the previous release )

Release 3.71b

  1. Small but important fixes notified by the community. This release is the #90 revision of svn version. For more information about the fixes you can browse http://izapvideos.googlecode.com/ .

Release 3.7b

Enhancement

  1. Favorite videos feature.
  2. All forms are re-written to decrease php overhead.
  3. All reported bugs have been fixed.

Release 3.62b

This release is more concerned to the bugs we are getting requests to get resolve. I would request to all of you to get involve in this testing.

Enhancement

  1. New flash player for on server videos.
  2. Queue reset option from admin panel.
  3. Compatible with elgg (1.5.1, 1.6.2 and 1.7.1).

Fixes

  1. View counting issue.
  2. Better pdo_sqlite drivers loading.
  3. Now there should be no Warning, Notice in error.log by izap_videos. Let us know if you could find something regarding that.
  4. We worked to suppress even deprecation messages due to newer elgg versions. System will make function calls according to the version of elgg.

Release 3.61b

Cool enhancement

  1. We decided to removed "izap_videos" from URL. now you can enjoy urls like "www.xyz.com/pg/videos/xxxxx". Complete branding for you :).

Fixes

  1. Small fix in video play page for elgg 1.6.1 and elgg 1.5

Release 3.6b

In the previous release we added the support to monitor the actual ffmpeg process to be sure about if queue is running or not. But that was behaving different on different server configurations (dual core, cord core). Number of cores effect on the number of threads of ffmpeg and hence background processes. So that's why it was behaving differently on different flavor of servers. To over come this, we stop this monitoring and start to see the queue status via sqlite db. And i tested it alot here, and it's working perfectly and now we also restored windows support. WAMP is tested with this version.

Release 3.55b:

In the previous release, We got so man y queries regarding intense database load of background process. And even some shared hosting providers having ffmpeg support banned some accounts because of eating of lots of database resources by the background processes. Reason of this was obvious, Queue is working in background and we were saving all queue elements as elgg object in database. And used elgg framework, we all know. Database is the thing where we need to take it seriously. And more over izap_videos plugin need to be optimized according to the demanding feature in almost every social networking site. So we solved this by using Sqlite queue management. To see result you can just try http://elgg.izap.in

How do we planned stability in this version:

In this version we have removed complex video conversion preset command and use simple ffmpeg command "ffmpeg -y -i [inputfile] [outputfile]". I setup a testing lenny instance of a server. than simply install ffmpeg using lenny package manager. And setup elgg with izap_videos. And it was working perfectly there was not any issue. Please post your feedback. And if it works for you. than post your server environment and give us one recommendation. As we will reach to the recommendation of 20. We will change this beta release to stable one.

  1. You can control plugin setting either you want to keep original video file after conversion
  2. Sqlite implementation to cut down all background processing.
  3. More control in queue management.
  4. Implemented Trash, This will just put videos in trash having any issue. it could be ffmpeg supporting libraries. Admin can delete them or can restore them after fix.
  5. Cron implementation to re-trigger queue in case of sudden interruption in the queue. You can manage cron timing according to your need.

Upgrading from previous release:

  1. Backup your database and izap_videos folder.
  2. Disable izap_videos plugin from your admin panel.
  3. Download and unzip izap_videos version 3.5 and place it in mod directory.
  4. Re-enable this new izap_videos plugin from you admin panel.
  5. You may need to re-enable ON-SERVER support from setting tab of izap_videos plugin settings.
  6. Clear simple cache.

New installation:

  1. Download and unzip the plugin in your mod dir.
  2. Enable it from admin panel.
  3. Clear simple cache.

ONSERVER Prerequisites:

  1. PDO sqlite drivers must be installed. This release and all future release will support queue management using PDO sqlite.
  2. ffmpeg and all supporting libraries.

Optional Prerequisites:

  1. notifications p lugin
  2. crontrigger plugin
  3. messages plugin

Optional plugins will give you better control over izap_videos plugin. These optional plugins are only required for ONSERVER support. If you leave them, izap_videos will yet to work with its basic functionality.

Bug fixes:

  1. Access control of uploaded video.
  2. Cutdown elgg-db communications to save resources
  3. Delete video entity will also delete all related media.

Compatiblility:

  1. Elgg 1.5
  2. Elgg 1.6
  3. Elgg 1.7a
  4. Elgg 1.7

Operating system compatiblity:

  1. *nix (confirmed)
  2. Windows (working perfectly tested with WAMP)

We are releasing beta release so we could collect feedback from all of you. Post your tickets at https://izapvideos.googlecode.com

I am twitting on: http://www.twitter.com/the_izap

I am blogging at: http://www.tarunjangra.com

Follow below our group discussion:

http://community.elgg.org/pg/groups/forum/340718

Comments

  • lord55 1264 days ago

    @izap thanks for this upgrade

    in Activity Widget there is a problem to resize the player, specially for embeded videos not from youtube.

    if I add in minilistElement

    $info .= elgg_view('categories/view', $vars);

    i can't see categories name

  • adoi 1263 days ago

    Find an error in adding metacafe videos 

    Fatal error: Call to undefined function c() in /home/******/public_html//******/*****/mod/izap_videos/lib/video_feed.php on line 112

     

    However embedded video is working well

  • ura soul 1263 days ago

    i have added a video from vimeo and found that the thumbnail produced came from about 1:10 into the video.. the thumbnail generation string is set to:

     

    /usr/bin/ffmpeg -y -i [inputVideoPath] -vframes 1 -ss 00:00:20 -an -vcodec png -f rawvideo -s 320x240 [outputImage]

     

    so this seems like a bug.. did i miss something?

    thanks

  • i Z A P 1263 days ago

    @tunist: this command is valid for only on server videos. So this is not a bug but intended to work so.

  • ghumanz 1263 days ago

    Hi, Izap

    I still have an issue with play video in river and on play page.

    BTW thanks for adding options to manage side bar , I already checked with IE and firefox both are not working . I already checked the header script but no problem there.

    One more thing  my videos are playing very well in profile widgets. I am using 1.7.4 with 666 theme

    any suggestions.??

  • TahoeBilly 1263 days ago

    I am getting that darn PDO_lite error on every page reload!!! I haven't enabled on server support. This is horribly annoying. I will look into changing my server when I have time, but now I must disable Izap and my YouTube videos just because of this error. Again, I never setup on server or made anything but standard install. Obviously getting this error every page reload it not going to work!

    Help?

  • OregonMike 1262 days ago

    Hi,

    I have 1.7.1. I disabled the izap video plugin I was using (made a backup) I then installed this latest one and then activated it.  I went to video settings and I only get the title

    Settings for iZAP Videos

    Nothing else.  Any ideas?

     

    Mike

     


  • ghumanz 1262 days ago

    @MontanaMike try to run www.yoursite.com/upgrade.php it will fix your problem.

    @Izap it is working for me now.Everything is good looking now. What I did, I uninstall the old version and remove the simplecache after that I upload the latest one and run a upgrade script . that works for me . After that now river video and other all are working well.

    Thanks

  • TahoeBilly 1262 days ago

    I have video on river, looks great, I am still getting the sqlite error even when I never selected on server videos. I am hoping to get sqlite working on my server and the error go away, but isnt this a bug?

  • OregonMike 1262 days ago

    I assume you mean www.yoursite.com/mod/izap_videos/upgrade.php right?

    I tried that with no change.

    Mike

     

  • Ron Wallace 1262 days ago

    Regarding www.yoursite.com/mod/izap_videos/upgrade.php. Are we suppose to run that after the install?? When I try I get the following error ...

    Fatal error: Call to undefined function datalist_get() in /home/xx/www.yoursite.com/xx/mod/izap_videos/upgrade.php on line 32

    Any idea why we are getting this fatal error??  Running 1.7.4.

  • Ron Wallace 1262 days ago

    I looked at the izap video discussion thread mentioned above and I find someone says "Well you no need to execute upgrade.php explicitly." --- Is that correct? Yet, it's mentioned above that others have run the upgrade.php without the fatal error. Kind of confusing - what' right or not.

    Since there is no mention of running this in the instructions, I guess there is no reason to do so. Am I correct?

  • DhrupDeScoop 1262 days ago

    function datalist_get is an Elgg core function not iZapVideos code - something else must be broken in your install ;-(

  • Ron Wallace 1262 days ago

    Well, maybe this version isn't ready for prime time. Sometimes videos load sometimes they don't. When they don't I get the following fatal error (just like adoi does above). When they do work, sometimes it requires two clicks to get the video to play other times not. All very weird. Here's the error that I get sometimes, not always, depends on where it's coming from...

    Fatal error: Call to undefined function c() in /home/xx/www.yoursie.com/xx/mod/izap_videos/lib/video_feed.php on line 112

    DhrupDeScoop - I don't know what else could be broken. Everything else is and has been working well - with no other indication that there is a problem. Only this version of izap video is causing the problems. Guess we'll go back to the older prior version which works well and wait for a new izap video to test.

     

  • DhrupDeScoop 1262 days ago

    LOLZ ;-)

    My problem seems to that I rarely get the kind of errors that get reported on the community ;) And I do mean that a lot of the errors I read about - I just do not understand. Perhaps the different technical perpectives...?

    Sometimes a second set of eyes solves the problem quickly - my trick when I cannot fix any issues fast. I get one of Elgg-Friends or my team members and ask "Can you see anything wrong with this code ?"nand within 1/2 a minute they say -- "what's that code doing?" and that's exactly where the error is !!

    I will install iZapVideos older version on my XAMPP 1.7.4 and see how the upgrade performs ;)

  • Ron Wallace 1262 days ago

    Interesting -- I went back to izap-videos 3.7.1b.

    I've never ever tried to run the www.yoursite.com/mod/izap_videos/upgrade.php. It never was in the instuctions, so I never tried it before on any iZapVideo version. I tired earier on the izap-videos 3.81b because it was mentioned above - and that is when I got the first error message.--- Fatal error: Call to undefined function datalist_get() in /home/xx/www.yoursite.com/xx/mod/izap_videos/upgrade.php on line 32

    So, now I tried it for the first time on izap-videos 3.7.1b. I get the SAME fatal error message. So, it happens on 3.7.1b as well as 3.8.1b. Further, I found on the izap-video discussion board that another user reported the same error message. This leads me to believe that there is something wrong with the upgrade.php script.

    And further, I tried to load the same video url that I got the Fatal error: Call to undefined function c() in /home/xx/www.yoursie.com/xx/mod/izap_videos/lib/video_feed.php on line 112 when using izap-videos 3.81b but this time using izap-video 3.71b. I DID NOT get the fatal error message. I rather got an error message that said "unsuported url". Which makes absolute sense.

    So it appears that the Fatal error message above in 3.8.1b should rather be offering a formal error message like 3.7.1b does -- which explains why sometimes I get the Fatal Error message and sometimes not. I should rather be getting a formal error message saying the url I'm trying to load is not supported, rather than issuing the fatal error message.

    We're going back to 3.7.1b cause it seems to be the cleanest version at the moment.

  • TahoeBilly 1261 days ago

    UPDATE on PDO_sqlite error

    My server company got back to me and said sqlite is installed....okay, so I am not checking "on server" video and I supposedly have sqlite installed and I get the error all the time pink box "please install sqlite on your server...." Can I just comment out this error?

  • Ron Wallace 1261 days ago

    It was suggested that a plugin may be the cause of this error --

    Fatal error: Call to undefined function datalist_get() in /home/xxx/www.yoursite.com/cxxx/mod/izap_videos/upgrade.php on line 32 when running the script www.yoursite.com/mod/izap_videos/upgrade.php --- so I disabled all non-standard plugin. Same problem. Still get the error message. So, it appears this problem is not plugin related.

  • iionly 1261 days ago

    @Ron: I believe the error with upgrade.php occurs due to PHP 5.3.X. At least I've got the same error with PHP 5.3 while it still works with PHP 5.2. It seems the lines

    if((real)datalist_get('izap_videos_version') < 3.55){
      // clears the old plugin settings
      if((real)get_version(true)< 1.7){

    cause the issue. You could try to modify these lines in upgrade.php according to your versions of izap_videos and Elgg, i.e. get rid of the if clauses and only keep what should be executed for your site. Hopefully, it will work then.

    But I don't know if other parts of upgrade.php are executed correctly either. I noticed that the changes in the database that should have been done at upgrading from izap_videos <3.55 were not executed on my installations - I only noticed this with one of the 3.6X versions. Maybe the script was not executed when upgrading from <3.55 and later on it never checked if the changes were done in the database already. Manually doing the changes via phpMyAdmin worked.

    Running upgrade.php and enabling/disabling izap_videos and making changes in its settings seems also work best with site caching disabled. Maybe also some other plugins like Minify should better be disabled until izap_videos is set up. Removing the izap_queue_db folder in the Elgg data directory sometimes also seem to help. I've not upgraded to izap_videos 3.8 yet but I had a few problems with earlier versions in the past but got it working after some time.

  • i Z A P 1260 days ago

    @ghumanz : There is no need to execute upgrade.php located in "izap_videos" plugin. And what you executed "www.yoursite.com/upgrade.php" is actually upgrade file for elgg not for izap_videos.

    @Ron Wallace: Yes there is problem with c() function. I forgot to remove after testing. Either you can just delete that function call. Or we will upload newer version with these small fixes.

    @iionly: <3.55 executes only if anyone have older version of izap_videos than this 3.55 version. And in most of the cases, it would not execute. And this upgrade.php is not doing any thing special but upgrade the version of izap_videos in the metadata called "izap_videos_version".

    We had some more fixes on http://izapvideos.googlecode.com. If you need you can export from there too.

    Thanks

     

     

  • TahoeBilly 1260 days ago

    Hey Izap! What about me and my error message about sqlite? This is not small problem I cant run Izap and I need it!

  • i Z A P 1260 days ago

    You can also download current snapshot of izap_videos from http://pluginlotto.com. Here's the direct URL http://www.pluginlotto.com/pg/store/product/241/10-1-more-reasons-to-upgrade-to-izap_videos-381b/

    @TahoeBilly: Well sqlite is required for onserver feature. If you disabled that onserver feature than i believe, plugin won't ask for sqlite driver. It might possible, you have some caching issues.

    Are you installing on fresh elgg?

    Upgrading from previous version of izap_videos plugin?


    Thanks

     

  • ghumanz 1260 days ago

    @IZAP and MIke I am not talking about to upgrade the IzaP script. I already faced the problem before removeing the cache of elgg site after installing new version. That's why I said to run www.yoursite.com/upgrade.php. Right now I have no problem with anything It is working very well.

    @iionly I am runing the new version of izap videos on php 5.3.3 and have no problem at all. Please remove old version of izap videos first and then clear cache and then try to install new version. It may be helpfull to you.

  • Ron Wallace 1260 days ago

    iZAP, you said ... "Yes there is problem with c() function. I forgot to remove after testing. Either you can just delete that function call. Or we will upload newer version with these small fixes." 

    Personally, I'd rather not modify the code. We are users not coders. So, if you would upload a newer version it would be most appreciated.

    Question: It appears our iZap-videos has been working without any problems - what kind of problem should we have noticed by not having the upgrade.php executed?

    Thank you for your prompt attention. I look foward to the new version.

  • Ron Wallace 1260 days ago

    iionly, you said... "...Manually doing the changes via phpMyAdmin worked.". Since I don't have the slightest idea what the upgrade.php's purpose is, I wouldn't have the slightest idea what changes to make via phpMyAdmin. What kind of changes did you make?

    Our izap_videos install appears to be working and has been working for a number of versions and upgrades, so, I wonder what we have been missing out on by not having the upgrade.php run properly. Any idea?