Log in

izap videos 4.2.0b (Youtube Upload / Onserver upload + Embed urls) (10 Jan, 2013) for Elgg 1.7

Full featured video plugin by iZAP

Last updated 468 days ago

izap_videos is a full featured videos plugin for elgg. It can handle YouTube videos upload, On server upload if you have dedicated resources to process videos and off server videos (YouTube, Vimeo, Veoh, Blip, CollegeHumor, 5min etc.).

  1. It supports YouTube uploads if you do not have dedicated resources to host/process uploaded videos by your users.
  2. It supports Youtube, Vimeo, Veoh, Metacafe, Blip, CollegeHumor, 5min.
  3. It also supports Off server videos. Where you can convert video files to flv at your own server. It needs ffmpeg compiled on your server. Supported formats are subject of what your ffmpeg compilation supports.
  4. More sharing options (Twitter, Facebook, LinkedIn, MySpace).
  5. A new customizable flash player. You can change forground and background colors of the flash player according to your need.
  6. Embeddable video code to post videos on other sites which are uploaded on elgg's platform.
  7. Categories support.
  8. River support.
  9. Groups integration.
  10. Now you can enable on server and off server in parallel mode.
  11. Make your videos favorite.

Recommend izap-videos if you really like what we did.

Release Notes:

izap_videos 3.9b revision 134:

  • Fixes in API. Now you can register API at pluginlotto.com for localhost / user.
  • Hidden edit form fixed.
  • Enhanced API with dedicated support of Youtube, Vimeo, Veoh, Metacafe, Blip, CollegeHumor, 5min.
  • Improved sqlite drivers for video queue management.
  • Lighter code.
  • Nice rating video widget.

Dependency:

  • izap-elgg-bridge, Get your copy from http://www.pluginlotto.com.
  • Install latest izap-elgg-bridge and place it on the top of all plugins provided by iZAP. This has some common libraries we need in our different plugins. It's let us maintain DRY programming practices.

Supporting elgg platforms:

  • elgg 1.6
  • elgg 1.7

Comments

  • jckm2000 1175 days ago

    Hi,

    Thanks for the plugin, However I can't get a copy of izap-elgg-bridge because pluginlotto isn't sending out confirmation emails. I've tried f ew times now with different email/username combos but no dice. Checked junk folders too but they're not there..........

    Could someone activate me manually?

    Cheers,

     

    Jon

  • Christian Avontuur 1175 days ago

    Hi, Installed this plugin...

    But after a video upload the video is not going through the qeue...

    Any ideas?

    @Jon (jckm2000) You can login with your google account!

  • TahoeBilly 1174 days ago

    Okay maybe I just need to find video settings but where is that? I have Vazco topbar and I see it nowhere so far to add the bridge.

  • Alan 1173 days ago

    Okay, so I've tried everything and nothing seems to work. Here's my problem: after installing this plugin the first time several days ago, I tried to test the ONSERVER video feature. After I tried that the first time, every time I try to visit the video settings admin page, I get this error:

    izap vids error

    I've tried clearing the cache multiple times, as well as removing and reinstalling both the bridge and videos plugin. I've deleted both the bridge and the vids plugin from my server and uploaded fresh copies of each, too, but even that doesn't work. I tried working on my site with the simplcache off thinking it might be that, but still to no avail.

    So ... what to do now?

     

  • TahoeBilly 1172 days ago

    I have completely lost the plot on this. I have the Izap plugin loaded and it shows no version, no info in plugin manager, as if it was loaded with a sub directory. I then go and try to get the API, I thought I get a set of files and an API? To be honest, I haven't a clue what I supposed to be getting, though it does generate an API key for me. Wasn't there a file set also? When I go back to my site I get a white screen and a "save" button. I never see a place to enter any API.

    Maybe you guys could make this a little more confusing that it is!

  • kxx4 1171 days ago

    How can I get this izap installed. I copied to the mod folder ,and the tool page on my administors page goes white and does nt load

  • Igor Nuk 1171 days ago

     How can I get a copy of izap-elgg-bridge? Right now it is not possible to register to pluginlotto, website is not sending out confirmation emails,therefore it is not possible to download the file.

  • kxx4 1170 days ago

    I am having the same challenge as Igor Nuk.

  • TahoeBilly 1169 days ago

    This plugin is what in San Jose California they call "vaporware"!

  • lord55 1167 days ago

    for me it doesn't work with jquery 1.4+, only with jquery 1.3.2

  • lord55 1167 days ago

    izap bridge calls another jQuery Form Plugin, there is one in elgg by default.

    is it possible to disable rating system in settings? a lot of javascript, someone use like/dislike

  • Invisible 1164 days ago

    @TahoeBilly, WOW !

    5th Most Recommended Plugin

    7th Most Download Plugin

    12416 Downloads

    34 Recommendations

    134 Revisions

    Almost 2 Years of Regular Updates, and full feedback

    And Still someone calls it "vaporware", If couple of people are not able to install it properly..

    Did i said something wrong.............. :) Pardon me... ;)

    If still not satisfied, Try this

    http://www.google.co.in/search?sourceid=chrome&ie=UTF-8&q=izap_videos

     

     

     

     

  • i Z A P 1164 days ago

    We are aware of registration emailing issue on pluginlotto.com. http://www.pluginlotto.com is hosted on shared hosting. And we alreaddy crossed our emailing limit.

    I just setup instances on amazon cloud for http://www.pluginlotto.com. http://www.pluginlotto.com is scheduled to be down at IST 15-Feb, between 10:00 PM to 12:00 PM .

    Note: http://api.pluginlotto.com is hosted on separate server. So it will be continue to server.

    Thanks

  • NoobyNoob 1164 days ago

    Anyone has problem on Elgg 1.7.6 ?

    I get a blank screen when adding youtube url (tried izap 3.7b, 3.81 and latest)

    url it gets stuck on with blank screen is  /action/izapAddEdit  ???

    Thanks.

  • i Z A P 1162 days ago

    Pluginlotto.com has been moved to amazon cloud. And is sending mails. Let me know if  you face any difficulty.

    Thanks

  • jeyner gil caga 1161 days ago

    Hi All,

    How much memory is consumed by this application?

    I have installed elgg 1.74 and izap 1.7 to a shared server and my account was suspended due to high CPU usage.

    Top Process     %CPU 24.0       /usr/bin/php /path/mod/izap_videos/izap_convert_video.php izap web
    Top Process     %CPU 23.0       /usr/bin/php /path/mod/izap_videos/izap_convert_video.php izap web
    Top Process     %CPU 22.0       /usr/bin/php /path/mod/izap_videos/izap_convert_video.php izap web

    Basically, JustHost is only allowing 10% CPU usage for each account.

    Also, for thos who have used this, which web host you are using?

    Thanks,

    jeyner

  • ura soul 1160 days ago

    @izap team: the video upload function has not worked on my site since the recent changes and i have not found a version of the izap plugin that does allow uploads.

    do you have a fix for the video uploads on this latest version?

    thanks

  • LJager 1154 days ago

    I was excited about using this plugin but being forced to register before being able to download the bridge plugin has put me right off.  I already have more accounts floating around cyber-space than I can keep track of so see no point in creating another for something that really should be included in this directory (it's an elgg plugin and is required to allow this one to function)... :-/

    Is this going to be permanent or will it be added here at some point in the near future?

    Thanks,

    LJ

  • Siamak 1154 days ago

    Hi,

    I installed izap_videos. Under "Add new video" it has two tabs 1- "Add url 2- Add embed code.

    The firs option (Add url) is not working properly. I receive the following message when I use this option:

    Your API is invalid or banned. Register new API at http://www.puginlotto.com.

    I already registered and got my key. The second option (Add embed code) works good.

    Also in the list of vidoes (My Videos) the icon for each vidoes is set to default izap icon.

    Any idea would be greatly appreciated.

  • Siamak 1154 days ago

    Hi,

    It's me again. Ironically, now "Add by url" is working without any problem but the other option "Add embed Code" is not working. When I am trying to add a video (like a youtube video) by embed code, it gives me "Please enter the embed code" each time.

    Can someone let me know what's going on!!!

  • gastre 1153 days ago

    When I upload and video, in the riverdashboard play auto when I refresh the riverdashboard!!!

    Any idea?

  • Jukka 1145 days ago

    We have Elgg 1.7.7. installed on Centos 5.5

    I have installed izap-bridge ja izap_videos plugins. Everything should be ok. Curl, ffmpeg and so on. Problems started when i tried to enable video uploading. Now when i try to go to izap_video settings error message below comes, so i can not disable video uploading any more. Before that external video linking was ok. Also when i try to select tools and videos same error message comes

    PHP Fatal error: Call to a member function prepare() on a non-object in /usr/local/apache2/htdocs/elgg/mod/izap-elgg-bridge/lib/classes/IzapSqlite.php on line 45

    We have PHP 5.3.5, Apache 2.2.17 and MySQL 5.5.9
    Bridge and izap_videos are last versions. 3.9b_r134 and r115

    pdo-sqlite drivers should be ok. php -m looks like this:

    Core, ctype, curl, date, dom, ereg, exif, ffmpeg, fileinfo, filter, gd, hash, iconv, imagick, json, ldap, libxml, bstring, mysql, pcre, PDO, pdo_sqlite, Phar, posix, Reflection, session, SimpleXML, SPL, SQLite, sqlite3, standard, tokenizer, xml, xmlreader, xmlwriter

    and phpinfo:

    PDO
    PDO support enabled
    PDO drivers sqlite, sqlite2

    pdo_sqlite
    PDO Driver for SQLite 3.x enabled
    SQLite Library 3.7.3

    izap-elgg-bridge is also on the top of all izap plugins

    sqlite version is 3.3.6-5

    Any suggestions what to do?

    ~ Jukka ~

  • xmlMaster 1144 days ago

    I'm having exactly the same problem as Jukka. When adding manually path to 'new PDO()' it doesn't give me the error, but still uploading doesn't work because it says i'm missing tokens. Help would be great!

  • ura soul 1143 days ago

    @izap: i, for one, would appreciate greatly if you would change the main version number of each release of the plugins.. having two 3.9b plugins is a bit confusing!

  • ura soul 1143 days ago

    i just installed the latest version of izap_videos and izap_bridge.. i am still seeing: 
    'error fetching data from remote url. either wrong url or video not found'.

    +

    exec and php interpretter entries on the server analysis page are 'fail'... these worked in previous versions.. i am not sure what the cause of the 'fail' message is... 

    (also the izap bridge settings panel in the admin is empty.)