Log in

Tidypics Photo Gallery Plugin for Elgg 1.8

Full-featured Photo Gallery plugin

Last updated 647 days ago

FEATURES

  • Albums
  • Comments
  • Tagging
  • Slideshow
  • Watermarking
  • Upload multiple images at once (web form or flash uploader)
  • Album sorting
  • RSS feeds
  • Notifications
  • Activity (river) integration
  • Views counter
  • Group albums
  • Admin Customization: supports GD and ImageMagick, quotas, size restrictions, and more

Release Notes:

Updated for Elgg 1.8

Thanks to Brett for significant contributions. Make sure you run the upgrade script.

This is a release candidate which means there is not going to be any significant development before the final 1.8 release. Changes will be bug fixes.

Please make useful bug reports (report browser information if browser related, report server information if server related).

Comments

  • kisssssss4ever 647 days ago

    WOW finally I can see Tidypics latest release, awesome.

    I am gonna try, thank you so much Tidypics Team

     

  • Matt Beckett 647 days ago

    Cash I think you just made everyone's day  :)

  • kxx4 647 days ago

    I activated this latest version, but it seems not to be functional in elgg1.8.1

  • Tidypics Team 647 days ago

    The above comment by kxx4 is a perfect example of a comment that is not useful. Please leave useful bug reports (what is not working, what steps you took, browser details if broswer related, server details if server related).

    I just tried on 1.8.1 and it works. The admin area of Tidypics uses tabs which I guess were not implemented until Elgg 1.8.3 so the tabs won't work. But you should still be able to set your settings or use the default settings.

    Also, in general, I would upgrade from Elgg 1.8.1 - the 1.8 releases weren't quite stable then (usable, but 1.8.2-1.8.4 really made big improvements in performance and number of bugs).

  • DhrupDeScoop 647 days ago

    woiky fine @ 1.8.6 @SeaMonkey - incl flash mass uploader (everyone's fave;). i'd expect far fewer gripes @now.

  • DhrupDeScoop 647 days ago

    if y'all want to pose useful problem reports, try supplying info like this :-

    1. Elgg version#
    2. Browser Name & version#
    3. At Which page (URL) were you just before the error. issue
    4. At which page (URL) does the error.issue occur
    5. What results/ content did you expect to see
    6. What is the error message )if any is visible)
    7. What 'log' and the log item's texts did you look up to figure more about the issue

    Such info helps Developers to help you get the issues resolved is a better manner

     

  • Aniket Kadam 647 days ago

    hey wow nice u know you people are amazing, i have been a part of many communities but this community is awesome and peope here are so helpful. Thanks for this wonderful Plugin.

    Can you tell me people, how to use the Flash uploader which this plugin (uses to upload photos) to integrate with core file plugin it would be nice to upload files the same way as we upload photos with the help of this plugin.

    Please Help

     

  • SkyForum 647 days ago

    Also having trouble with flash uploader. I could not get it to work at all. Kept getting HTTP Error. I could upload one image via the manual uploader.

    I seemed like a mod_security issue so I added the following;

    SecFilterEngine Off
    SecFilterScanPOST Off

    to my htaccess file and was able to get the uploader working for a single image. Still cannot upload multiple images in Firefox however, (will allow me to select, but all images after the first one still display HTTP Error)

    • Release 1.8.8
    • Firefox 13.01
    • On a linux VPS with PHP 5.3.8
    • Using GD library

    Now, went to IE9 and tested. LOL! For the first time EVER, IE9 worked flawlessly with the flash uploader and the modified .htaccess.

    Just to make sure it's not a mod_security issue, I then commented out the SecFilterEngine Off
    SecFilterScanPOST Off and tried IE9 again.

    It failed. Immediately got the HTTP Error message again.

    Two distinct issues, one with some users mod_security settings and the other with Firefox.

    I am a new user here so forgive me if I make a mistake.

     

  • Per Jensen 647 days ago

    Tested on,

    Elgg 1.8.8, FF

    Everything went smooth with the basic uploader. Flash uploader gave "HTTP Error".

    Image with danish character in title failed to upload.

    Watermark does not show.

    Great to have tidypics back. Just a few UI ideas,

    It would be nice to have the "Use as Album Cover" option during album cration.

    When I look at /photos/image/... I miss a link back to /photos/album/...

  • Cash 647 days ago

    @gillie need to know what image library you are using (GD, imagick, ImageMagick command line) for the watermarking. It tested out fine for me but it is very faint.

    Link back to album is in the breadcrumbs

    @everyone else - I'll do some more testing with mod_security to see if there are some work arounds. Thanks to SkyForum for the detailed report.

  • LeGuiGuitoux 647 days ago

    Where can i see a demo of this plugin? thx you

  • Per Jensen 647 days ago

    I was using ImageMagick which does not work.

    GD works.

    Tidypics test feature gives this result about ImageMagick,

    ImageMagick 6.6.7-0 2011-01-07 Q16 http://www.imagemagick.org Copyright: Copyright (C) 1999-2011 ImageMagick Studio LLC Features: OpenMP

  • kisssssss4ever 647 days ago

    Friends, I have one tidypics which works 100% perfect for me on my 1.8.8 and also I tested on 1.8.7. I am not sure that would work perfect on other elgg versions. I am new to elgg I did some modification on my own after great struggle when tidypic was a dream that time I made it work on my own. If you think I can post that plugin here and its allowed to post, then I would happily post here for all of you guys.

     

    Kindest Regards

  • Matt Beckett 646 days ago

    @kiss it's more productive to look at the modifications you made and see if it's useful to patch back to the official version.  It's confusing and counter-productive to have alternate forks of the same plugin floating around.

  • kisssssss4ever 646 days ago

    Yes Matt, that's why I asked you guys permission :) 

    Thanks for the prompt reply!

  • kisssssss4ever 646 days ago

    Friends, I tested this plugin on my 1.8.8, works perfect for me and I am using custom theme as well with other plugins. So I think I won't share the one I have, because this is also working fine to me.  Good Luck everyone :)

  • kisssssss4ever 646 days ago

    The only is not working in my own tidypics and in this tidypics is slidshow :(

    In Google chrom works perfect but I tested now on mozila slidshow does not please Tidypics Team try to fix slidshow on some web broswers do not work because personally I tested on Mozila does not work at all :(

  • Cash 646 days ago

    You can post modifications here: https://github.com/cash/Tidypics There is an issues tracker where you can post code/ideas.

    Slideshow works fine for me using Firefox.

  • meril 646 days ago

    tested on elgg 1.8.8 everything works perfectly... with chrome exept flash uploader it fails for multiple photo upload... i can just upload one image using flash uploader... for rest of the image it gives http error..

    php version 5.3.13

    linux VPS server

    Thanks for this grate plugin...

  • Vagsiarom 646 days ago

    great plugin, works perfectly in 1.8.6

  • Per Jensen 645 days ago

    Widgets,

    Pagination shows up and "More Photos" link missing.

  • İşöğüçı 645 days ago

    Does anybody have an observation of photos not displaying properly (or rather, displayed only with their names)?

    In my environment this seems to be due to a conflict with another plugin (when that disabled,no problems) of completely different functionality.

  • iionly 645 days ago

    What's the name of this other plugin that interferes with displaying of photos?

  • İşöğüçı 645 days ago

    I am sure I am doing something wrong. The other plugin is URLshortener. It just does not make sense. I suspect something else is wrong with my environment and this is just circumstantial otherwise what does that plugin has anything to do with tidypics?

     

  • rjcalifornia 644 days ago

    Hi,

    Elgg version: 1.8.8

    Operating System: Mac OS Leopard PPC

    Browser: Firefox and Safari

    Issues: None

    I used the flash uploader with no issues. I also tested Cool Iris and it worked with no issues.

    Just one question: Is there a way to set Cool Iris as the default picture viewer for tidypics?